Re: PSF2 Problems

[ Post a new reply ] [ Back to the message board ]

This message was posted by Cush, posted on January 07, 2002 at 11:34:01 coming from 63.120.110
This message is a reply to Re: PSF2 Problems posted from The Dumper posted at January 02, 2002 at 20:04:39
> > Hey all, I got a problem with my Professor SF II. I was loading a game (via the floppy drive) and all of the sudden, it reported a disk error. Trying to load any game from that point on has resulted in a disk error. I found out why; it doesn't look like the disk drive is getting power anymore. When I provide power to the unit, the disk light never comes on. The OS/menu, however, DOES come up. I've taken the thing apart and have limited electronics experience. My first guess is to apply a voltmeter to the red/white whites leading to the disk drive to see if power is getting to it. I've also tried swapping disk drives with a standard 3.5 floppy drive. Past that, nothing appears to be wrong with the PCB. Can anyone point me in the right direction to troubleshoot?

> > Cush

> You are using an external power supply, right?

Yes...I have one I got at Radio Shack...10V, 850mA that plugs into the back. Since the OS loads when it has power and the OS doesn't load if I turn the SNES on without power, I'm assuming the power supply is still good. (I've burnt one or two out before).

Cush


Responses to this messages:


Post a Followup

Name
E-Mail
Subject
Message
Optional Link URL
Optional Link Title
Optional Image URL
Please pick a mood
for your message: